Beveiligingsexperts hebben een nieuwe bug gevonden waardoor miljoenen apparaten en apps kwetsbaar zijn om over genomen te worden door hackers. 

Google heeft inmiddels een patch uitgebracht om het probleem te verhelpen. Er zijn geen gevallen bekend waarin de bug al is misbruikt door hackers, meldt de BBC.

Door de kwetsbaarheid zou het in theorie mogelijk zijn voor hackers om een vaakgebruikt stukje code te misbruiken om van afstand toegang te verschaffen tot een apparaat, zoals een computer, router of een ander met het internet verbonden apparaat. 

De zogenoemde Glibc-bug zit in het besturingssysteem Linux, en kan ook voorkomen in belangrijke programmeertalen zoals PHP en Python, de talen waarin belangrijke delen van het internet zijn geschreven. Ook Android is gedeeltelijk gebaseerd op Linux, maar is niet kwetsbaar door de bug.